Como obter o mês ou ano de uma data no Microsoft Excel

Um calendário ao lado de várias tachinhas coloridas em uma superfície roxa.

As datas no Microsoft Excel são úteis para rastrear finanças, pedidos e vendas. Portanto, pode chegar um momento em que você queira retirar um mês ou ano de uma entrada de data. Funções e fórmulas tornam esta tarefa fácil.

Existem algumas maneiras de obter um mês a partir de uma data no Excel , dependendo se você deseja exibir o resultado como um número, palavra ou abreviatura. E, felizmente, você pode usar esses mesmos métodos para obter o ano a partir da entrada da data.

Obtenha o mês ou ano com funções de data

Se você deseja obter o valor numérico de um mês, como 10 para outubro, 11 para novembro e assim por diante, a função MÊS realiza o trabalho rapidamente. Durante anos, você pode simplesmente usar a função ANO e uma referência.

A sintaxe de cada função é a mesma:

 MONTH(reference) 

e

 YEAR(reference) 

onde você se refere à célula que contém a data.

Você pode usar as seguintes fórmulas para obter o mês e depois o ano a partir da data na célula A2:

=MÊS(A2)

=ANO(A2)

Você verá então o resultado na célula que contém a fórmula.

Função ANO para obter o ano a partir de uma data

Lembre-se de que o mês é formatado como valor numérico.

Função MÊS para obter o mês de uma data

Se você tiver uma lista de datas nas quais deseja obter o mês e/ou ano de cada entrada, use a alça de preenchimento para arrastar a(s) fórmula(s) para as células restantes.

Copie a fórmula para as células usando a alça de preenchimento

Obtenha o mês ou ano com a função TEXT

Talvez você prefira ver o nome do mês ou uma abreviatura em vez do número. Você pode fazer isso para o mês usando a função TEXTO . Você também pode obter o número de dois dígitos do ano com este método.

Recomendado  Como converter quase qualquer unidade no Microsoft Excel

A sintaxe da função é TEXT(value, format_code)onde você precisará de ambos os argumentos para exibir o mês. A valueé a célula que contém a data e format_codeé como você deseja exibir o resultado.

Aqui, obteremos o mês da data na célula A2 como uma palavra completa usando a letra M de mês como format_code:

=TEXTO(A2,"mmmm")

Observe que você precisa de pelo menos quatro M entre aspas para obter o nome completo do mês. O número de letras do nome do mês não corresponde ao número de M no argumento; basta inserir pelo menos quatro deles.

Nome completo do mês usando a função TEXT

Para obter a abreviatura de três letras de um mês em vez do nome completo, basta usar três M’s:

=TEXTO(A3,"mm")

Abreviação do nome do mês usando a função TEXT

Você também pode usar a função TEXT se quiser apenas dois dígitos para o ano, em vez de todos os quatro. Você usará a letra Y para ano como format_code:

=TEXTO(A2,"aa")

Dois dígitos para o ano usando a função TEXT

Novamente, você pode usar a alça de preenchimento para copiar as fórmulas para as células restantes, se desejar.

Copiamos fórmulas para células usando a alça de preenchimento

Extrair um mês ou ano de uma data completa no Excel leva apenas um minuto com esses métodos. Para obter mais informações, verifique essas funções adicionais de data e hora no Excel que podem ser úteis.